오류내용


새 시스템 파티션을 만들거나 기존 시스템 파티션을 찾을 수 없습니다

Windows 7 , Vista 설치시 디스크 파티션을 설정하는 부분에서 주파티션을 설정 후 다음(Next) 를 눌러도 아래와 같이 오류가 나오며 더 이상 진행이 되지 않는다. 모든 파티션을 삭제 후 다시 주파티션을 1개로 또는 2개이상으로 나누어 만들어보아도 역시나 오류가 나면서 진행이 되지 않는다.

주파티션에 설치 진행 > 실패
주파티션 삭제 후 진행 > 실패
모든 파티션 삭제 후 진행 > 실패
DISKPART 에서 ACTIVE 로 활성화를 주어도 > 실패



Setup was unable to create a new system partition or locate an existing system partition.
See the Setup log files for more information.

새 시스템 파티션을 만들거나 기존 시스템 파티션을 찾을 수 없습니다. 자세한 내용은 설치 로그 파일을 참조하십시오.






diskpart 를 이용해서 active 을 주면 된다는 주의의 말에 해보았으나 역시나 되지 않았다.




윈도우 7 주파티션 설치 안되는 문제 해결 방법




바이오스 셋업창에서 SATA Configuration 의 속성을 IDE 에서 AHCI 로 변경한다. 변경 후 에는 아무 문제 없이 진행 된다.
AHCI 로 변경하면 HDD , SDD 에서 어느정도의 성능향상도 발생하니 변경을 가능하면 하기 바란다.

AHCI


고급 호스트 컨트롤러 인터페이스(AHCI, Advanced Host Controller Interface)는 소프트웨어가, 병렬 구조의 ATA (PATA)에서 제공되는 않는 기능(핫 플러깅 등)을 제공하도록 설계된 호스트 버스 어댑터와 같은 시리얼 ATA (SATA) 장치들과 신호를 주고 받을 수 있도록 만든 하드웨어 구조를 뜻한다. 이 규격은 시스템 메모리와 장치 사이의 데이터 전송을 목적으로 컴퓨터 하드웨어 제조업체들을 위한 시스템 메모리 구조를 자세하게 명시해 놓고 있다. 현재의 규격 버전은 2007년 7월 v1.2이다.[1]

많은 SATA 컨트롤러들은 AHCI만 따로, 또는 RAID 지원과 결합하여 사용할 수 있다. 인텔은 자사 메인보드에 AHCI/SATA 모드보다 AHCI와 더불어 RAID 모드를 선택할 것을 권하고 있다.[2]

AHCI는 마이크로소프트 윈도 비스타와, 커널 2.6.19의 리눅스 운영 체제에서 완전히 지원된다. AHCI 지원은 윈도 XP 미디어 센터 에디션부터 지원한다. (별도의 드라이버 설치를 하지 않는 한 유일하게 지원하는 XP 버전이다) 더 오래된 운영 체제들이 AHCI를 지원하게 하려면 호스트 버스 어댑터 제조업체가 제공하는 드라이버를 사용해야 한다. - 위키백과 -

신고

이 글은 "씨디맨" 의 동의 없이 전문 재배포 금지. 링크 및 트랙백은 허가 없이 무제한 허용 *  [자세히보기]

질문 또는 댓글을 남겨 주세요.

질문글은 무조건 답변 드리겠습니다. 이곳에 질문을 올려주세요.
이 글과 연관이 없는 급한 질문은 빠른 질문/답변을 이용해 주세요!

댓글 입력 폼

:)   :(   --;   :D   :O   :x   r:r   g;g   i;t   s;s

     이미지 업로드  [무료이미지 업로드 방법 설명]

  1. 이전 댓글 더보기
  2. 오오 2013.02.04 15:30 신고

    주인장과 댓글 달아주신 분들 정말 감사합니다.

    다 보면서 따라하고 있었는데 USB 다른 곳에 꽂았더니 한방에 해결되었어요.

    많은 분께 알리고 싶군요! 이렇게 간단한 해결방법이 있을 줄은;;

    perm. |  mod/del. |  reply.
  3. 푸히히 2013.07.30 22:39 신고

    다필요없고 그냥 usb 잠시 빼둔상태서 다음 누르면 에러가 떠요~그때 usb를 다른슬롯에 연결후 새로고침하고 다음 누르니 되군요

    perm. |  mod/del. |  reply.
  4. 김성 2014.01.27 13:00 신고

    와 파티션 삭제하고 하니까 바로 되요 ㅠㅠㅜㅠ

    perm. |  mod/del. |  reply.
  5. 컴맹 2014.04.24 11:04 신고

    Samsung SSD 840 PRO 250G 파티션 나눠서 win7을 설치해서 쓸려고 하는데 안됐는데...
    저는 AMI 바이오스 설정에서 sata gen3 mode를 disable로 하니깐 win7 설치가 됐어요. 혹시 저랑 같은 증상 있으시면 sata gen3 mode를 disable로 설정 바꾸고 해보세요

    perm. |  mod/del. |  reply.
  6. 대벅 2014.05.08 12:38 신고

    대박 글대로하니 바로 성공 ㅡㅡ

    perm. |  mod/del. |  reply.
  7. 2014.07.29 18:50 신고

    쩐다 감사합니다ㅠㅠ

    perm. |  mod/del. |  reply.
  8. ㅇㅇ 2014.11.01 18:30 신고

    외장하드 빼두니 되네요. 댓글에서도 도움 받아갑 니다ㅋㅋ

    perm. |  mod/del. |  reply.
  9. ㅇㅇ3 2015.04.06 04:42 신고

    제 경우 죄다 안되길래 이것저것 해보다가 댓글 참고해서 해결했습니다

    약관 동의 한다음에 usb 빼고
    고급 설치 누르고 디스크 파티션 나눈담에(350메가,나머지 2개 생김)

    x 눌러서 취소한다음에 설치(처음부분) 누르고
    약관 동의까지 똑같이 다시 해준다음에 usb 빼고
    다른쪽에 꽂은 다음에 고급설치 누르니 아까 생성한 파티션이 그대로 남아있고
    다음 누르니 정상적으로 넘어가졌습니다

    perm. |  mod/del. |  reply.
  10. 감사해요 2015.05.03 16:47 신고

    윈도우7은 usb3.0을 지원 안하더라고요~ 저도 usb다른 슬롯에 바꿔 껴보고 해보다 계속 실패했네요ㅠ 2.0으로 하니까 한방에 되네요~ 혹시 usb3.0인지 확인해보는것도 한가지 방법일듯 싶습니다~

    perm. |  mod/del. |  reply.
  11. Kevil 2015.08.06 20:56 신고

    너무 감사해요.
    부팅 순서로 해결했습니다.

    perm. |  mod/del. |  reply.
  12. 아이유짜응 2015.08.30 01:46 신고

    저도 외장하드 추가하드 제거하고 다시 시작했더니 언제 안됐냐는듯 바로 되네요 댓글분들 포스팅해주신분 모두 감사해요~^^

    perm. |  mod/del. |  reply.
  13. 나그네 2015.11.13 07:20 신고

    저같은 경우 시디로 설치중이엇는데, 이전에 꼽혀잇던 usb 빼고 바이오스 진입한후 다른 변경 없이 재부팅 하니깐 정상설치가 되는 군요. 아직도 뭐가 문제엿는지 모르겟습니다. 다만, usb를 빼고 나서 설치시디를 못하는 현상이 잇어서 몇번 재부팅해주엇구요. 바이오스 진입후 시디인식 설치 진행 되는 것으로 보아, usb가 꽂혀 잇엇던게 문제가 아니엇나 생각되는군요. 어째든 여기서 고군분투하며 사투하던 분들과 시디맨님 사랑합니다~~

    perm. |  mod/del. |  reply.
  14. 나그네 2015.11.13 07:20 신고

    저같은 경우 시디로 설치중이엇는데, 이전에 꼽혀잇던 usb 빼고 바이오스 진입한후 다른 변경 없이 재부팅 하니깐 정상설치가 되는 군요. 아직도 뭐가 문제엿는지 모르겟습니다. 다만, usb를 빼고 나서 설치시디를 못하는 현상이 잇어서 몇번 재부팅해주엇구요. 바이오스 진입후 시디인식 설치 진행 되는 것으로 보아, usb가 꽂혀 잇엇던게 문제가 아니엇나 생각되는군요. 어째든 여기서 고군분투하며 사투하던 분들과 시디맨님 사랑합니다~~

    perm. |  mod/del. |  reply.
  15. 망했다. 2015.12.16 22:09 신고

    질문드려요.
    메인보드로 asrock h110m hdv를 이용하는데, bios로 진입해서
    모든 메뉴를 다 뒤져보았지만 ahci로 바꾸는 메뉴가 없습니다.

    온라인을 통한 uepi?도 업데이트 해보았지만 없습니다.

    diskpart를 통해서도 깔려지지 않으며

    어떤 명령어인지 기억이 나지 않지만 타입이 주에서 시스템으로 바뀌면, mbr 디스크 어쩌구.. 오류가 납니다.

    저는 ssd 하나만을 연결해서 사용하고 있는데,
    ssd 문제가 아닌가 궁금한데 진단할 방법도 모르는데 방법이 없을까요?

    +
    http://bab2min.tistory.com/355
    방법을 이용해보아서 해봤는데
    마지막 bootsect를 실행하면, bootmgr 오류가 나지만
    usb를 빼도 윈도우 설치가 실행되길래 되는 줄 알았더니
    같은 오류가 나네요.
    ssd의 문제인지..

    perm. |  mod/del. |  reply.
  16. ㅇㅇ 2016.02.04 22:53 신고

    제 경우는 부팅순서가 문제였습니다.
    설치할 하드를 1빠로 놓고 2순위에 usb를 놓았더니 됩니다

    perm. |  mod/del. |  reply.
  17. 방문자 2016.05.11 12:28 신고

    윈도우10 해당오류로 고생했는데 설치할 드라이브 제외 케이블 모두 제거하니 한번에 됐습니다

    perm. |  mod/del. |  reply.
  18. 김효영 2016.06.05 16:16 신고

    덕분에 해결했습니다. 유용한정보입니다.

    perm. |  mod/del. |  reply.
  19. 마감전날 2016.07.28 22:13 신고

    윈10 마감 임박해서 부랴부랴 업뎃하다가 여기까지 왔는데 저같은 경우는 부팅순서 문제였네요. 바이오스 셋팅에는 OS설치할 하드를 1순위로 두고 부팅할때는 부팅옵션에서 usb로 설정하고 들어가서 설치하니 오류없이 진행됐습니다! 고맙습니다 ㅜㅜ

    perm. |  mod/del. |  reply.
  20. 황총 2016.09.16 12:21 신고

    감사합니다 ^^ 덕분에 해결하였습니다

    perm. |  mod/del. |  reply.
  21. 고문관 2017.01.14 08:44 신고

    정말 큰절 올림니다 꾸벅*무한대
    설치가 시작 되네요 흐흐흑
    두시간 만에...
    복 많이 받으시고
    건강 하시길 두손모아 빕니다^^

    perm. |  mod/del. |  reply.